Need help? Reach out at fae.so/contact. For everything else, head back to fae.so.
We've recovered from the iMessage infrastructure degradation and added more phone lines to support the load.
Most users should be able to reach Fae again. If your Fae is still unresponsive, please visit https://fae.so/help for recovery steps and a new number.
Resolved
We've recovered from the iMessage infrastructure degradation and added more phone lines to support the load.
Most users should be able to reach Fae again. If your Fae is still unresponsive, please visit https://fae.so/help for recovery steps and a new number.
Investigating
We’re experiencing degraded iMessage delivery due to an infrastructure issue. Some Fae numbers may not reply or may respond slowly.
If Fae isn’t replying, please visit https://fae.so/help to get a new set of numbers and add Fae as a contact again.
We’re working on a fix and expect to have this resolved tomorrow, May 28, 2026.